Odkaz: V Linuxu a OS X našli extrémně nebezpečnou chybu. Je 20 let stará

foto: shellshocker.net

V UNIXových operačních systémech nejsou chyby objevovány zdaleka tak často jako ve Windows, ale když už, tak to stojí za to. Kritická chyba v procesoru „Bash“ se týká většiny linuxových distribucí i systémů od Applu. V ohrožení jsou notebooky, servery, routery a spousta elektroniky.

Bash je nejrozšířenějším příkazovým procesorem, který vykonává „povely“ zadané prostřednictvím příkazové řádky. Často však jeho služeb využívají i samotné aplikace a programy. Jeho první generace byla vydána v roce 1989, nyní objevená chyba se však dostala až do verze 1.14 vydané v roce 1994. Nikdy neobjevená se dostala až do současného vydání 4.3, které využívá mimo jiné i poslední OS X Mavericks.

Zdroj: V Linuxu a OS X našli extrémně nebezpečnou chybu. Je 20 let stará – iDNES.cz

Záložka pro permanentní odkaz.

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *